Home Forums WordPress Plugins Hide My WP Adding HMWP on Bitnami WP stack

This topic is: not resolved

This topic contains 20 replies, has 2 voices, and was last updated by  Suman Maharjan 9 months ago.

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #19867
    vishanjad
    Active
    Post count: 11

    Hello support this is continuation of ticket on envato forum.

    Hello Support,

    I’m still not able to access the right .htaccess file shown in your video. I’m using Bitnami stack could you please tell me exactly which file on there to edit or send me the file?. And say where exactly to load it? Here is the WP MU version i’m running:

    https://bitnami.com/stack/wordpress-multisite
    Please take snapshot of the FTP folder structure so and indicate where folder/file should be place an edited.

    Thanks VIsh
    ____________________________________

    namus25
    namus25 AUTHOR TEAM
    If you are using bitnami, then please change AllowOverride None to AllowOverride All in httpd-app.conf file to use the .htaccess file. (httpd-app.conf is usually located at /opt/bitnami/apps/wordpress/conf/httpd-app.conf)
    ______________________________________________

    <IfDefine USE_PHP_FPM> <Proxy “unix:/opt/bitnami/php/var/run/wordpress.sock|fcgi://wordpress-fpm” timeout=300> </Proxy> </IfDefine>

    <Directory ”/opt/bitnami/apps/wordpress/htdocs”> Options +MultiViews +FollowSymLinks AllowOverride None <IfVersion < 2.3 > Order allow,deny Allow from all </IfVersion> <IfVersion >= 2.3> Require all granted </IfVersion>

    <IfDefine USE_PHP_FPM>
    <FilesMatch \.php$>
    SetHandler “proxy:fcgi://wordpress-fpm”
    </FilesMatch>
    </IfDefine>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [S=2]
    uploaded files RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    1.(DROP THE CODE HERE?) 2. ALSO I see no ‘[OR] at the end of line below. Should i add next to !-f [OR] </Directory>

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]
    Include “/opt/bitnami/apps/wordpress/conf/banner.conf”
    Include ”/opt/bitnami/apps/wordpress/conf/htaccess.conf”

    #19868
    vishanjad
    Active
    Post count: 11

    Please confirm line 6 counting from the last line up..

    #19875
    Suman Maharjan
    Post count: 9626

    Hi, first of all, make sure that you change “AllowOverride None” to “AllowOverride All” in httpd-app.conf file to use the .htaccess file

    Then in .htaccess file (just above the line “RewriteCond %{REQUEST_FILENAME} !-f”) add HMWP rules (from your site’s HMWP settings page)

    #19899
    vishanjad
    Active
    Post count: 11

    Ok so edit the httpd-app.conf to show “AllowOverride All” then go to the .htaccess file where?

    1. I see many ,htaccess files. Please provide path to where the correct .htaccess file is located.

    2. Is it same path where i found the httpd-app.cont (/opt/bitnami/apps/wordpress/conf/httpd-app.conf)?

    3. Because i see a .htaccess-conf file in the same path as httpd-conf.

    Please remember i’m using bitnami multisite stack which can be found here:
    https://bitnami.com/stack/wordpress-multisite

    Please provide those steps to me. Thanks in advance.

    #19904
    Suman Maharjan
    Post count: 9626

    The .htaccess file in WordPress root directory where wp-config.php file is located.

    #19924
    vishanjad
    Active
    Post count: 11
    This reply has been marked as private.
    #19925
    vishanjad
    Active
    Post count: 11

    I cant even send the file to you i get a 403 page. what nonsense is this!

    #19931
    Suman Maharjan
    Post count: 9626

    For HMWP plugin to work, you simply have to activate it and apply one of the pre-made settings from HMWP start tab. If htaccess file is writable you need not do anything further and you are all done, but if htaccess file is not writable you’ll need to copy HMWP rules from HMWP settings page and add it to htaccess file.
    But in your case as you are using Bitnami stack, and htaccess doesn’t seem to be activated by default. Can you please contact your hosting provider and have it enabled for you and know the location of htaccess file?

    #20132
    vishanjad
    Active
    Post count: 11
    This reply has been marked as private.
    #20143
    Suman Maharjan
    Post count: 9626
    This reply has been marked as private.
    #20157
    vishanjad
    Active
    Post count: 11
    This reply has been marked as private.
    #20162
    Suman Maharjan
    Post count: 9626
    This reply has been marked as private.
    #20176
    vishanjad
    Active
    Post count: 11
    This reply has been marked as private.
    #20184
    Suman Maharjan
    Post count: 9626
    This reply has been marked as private.
    #20220
    vishanjad
    Active
    Post count: 11
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 21 total)

You must be logged in to reply to this topic.