Home Forums WordPress Plugins Hide My WP Breaks template

This topic is: not resolved

This topic contains 6 replies, has 2 voices, and was last updated by  Suman Maharjan 3 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #20555
    victrim
    Post count: 3

    Dear support,

    I installed hide my WP to hide the wp template name. But whatever i do it keeps ruining my template. I already took a look at urgent help and i noticed the broken template information. Tried this but i still didn’t got it working.

    The plugin is disabled right now because it’s important to keep the website online.

    Hopefully you guys can help me.

    Here a debug report it says it could help you guys.

    ===========================================================
    WP Settings
    ===========================================================
    WordPress version: WP 4.9.4
    Home URL: http://www.laplazabrunssum.nl
    Site URL: http://www.laplazabrunssum.nl
    Is SSL: false
    Is RTL: false
    Permalink: /%year%/%monthnum%/%day%/%postname%/

    ============================================================
    Server Environment
    ============================================================
    PHP Version: 7.1.14
    Server Software: Microsoft-IIS/8.5
    WP Max Upload Size: 100 MB
    Server upload_max_filesize: 100M
    Server post_max_size: 100M
    WP Memory Limit: 40M
    WP Debug Mode: false
    CURL: true
    fsockopen: true

    ============================================================
    Active plugins
    ============================================================
    Hide My WP 5.5.6 [http://hide-my-wp.wpwave.com/]
    Easy Google Fonts 1.4.3 []
    Envato Market 1.0.0-RC2 [http://envato.github.io/wp-envato-market/]
    EWWW Image Optimizer 4.1.0 [https://wordpress.org/plugins/ewww-image-optimizer/]
    Grand Restaurant Theme Custom Post Type 2.9 [http://themes.themegoods2.com/grandrestaurant]
    Imsanity 2.3.10 [https://wordpress.org/plugins/imsanity/]
    Loginizer 1.3.8 [http://wordpress.org/extend/plugins/loginizer/]
    MailChimp for WordPress 4.1.15 [https://mc4wp.com/#utm_source=wp-plugin&utm_medium=mailchimp-for-wp&utm_campaign=plugins-page]
    Slider Revolution 5.4.6.3 [http://revolution.themepunch.com/]
    WooCommerce 3.3.3 [https://woocommerce.com/]

    ============================================================
    Plugin Option
    ============================================================
    {“li”:””,”import_options”:””,”export_options”:””,”iis_config”:””,”debug_report”:””,”help”:””,”undo”:””,”custom_404″:”0″,”custom_404_page”:””,”trusted_user_roles”:””,”replace_mode”:”safe”,”hide_wp_login”:”on”,”login_query”:”hide_my_wp”,”admin_key”:”1234″,”hide_wp_admin”:”on”,”spy_notifier”:””,”customized_htaccess”:””,”separator”:””,”cdn_path”:””,”email_from_name”:”La Plaza”,”email_from_address”:”noreply@testmail.com”,”antispam”:”on”,”full_hide”:””,”hide_other_wp_files”:”on”,”disable_directory_listing”:”on”,”disable_canonical_redirect”:””,”hide_admin_bar”:””,”avoid_direct_access”:””,”direct_access_except”:”index.php, wp-content/repair.php, wp-comments-post.php, wp-includes/js/tinymce/wp-tinymce.php, xmlrpc.php, wp-cron.php”,”exclude_theme_access”:””,”exclude_plugins_access”:””,”new_theme_path”:”/static”,”new_style_name”:””,”style_expiry_days”:””,”minify_new_style”:””,”new_include_path”:”/static/lib”,”new_plugin_path”:”/static/ext”,”rename_plugins”:””,”new_upload_path”:”/file”,”replace_comments_post”:””,”replace_admin_ajax”:”ajax”,”new_content_path”:””,”separator2″:””,”new_login_path”:”login.php”,”new_admin_path”:””,”separator3″:””,”api_disable”:”0″,”api_base”:””,”api_query”:”rest_route”,”author_enable”:”1″,”author_base”:””,”author_query”:””,”author_without_base”:””,”feed_enable”:”1″,”feed_base”:””,”feed_query”:””,”post_enable”:”1″,”post_base”:”/%year%/%monthnum%/%day%/%postname%/”,”post_query”:”p”,”page_enable”:”1″,”page_base”:””,”page_query”:”page_id”,”paginate_enable”:”1″,”paginate_base”:””,”paginate_query”:””,”category_enable”:”1″,”category_base”:””,”category_query”:””,”tag_enable”:”1″,”tag_base”:””,”tag_query”:””,”search_enable”:”1″,”search_base”:””,”search_query”:””,”nice_search_redirect”:””,”disable_archive”:””,”disable_other_wp”:””,”remove_html_comments”:””,”replace_javascript_path”:”0″,”remove_feed_meta”:”on”,”remove_other_meta”:”on”,”remove_default_description”:”on”,”remove_ver_scripts”:””,”remove_body_class”:””,”remove_menu_class”:””,”clean_post_class”:””,”clean_new_style”:””,”replace_in_ajax”:””,”replace_wpnonce”:””,”internal_css”:””,”internal_js”:””,”enable_ids”:””,”ids_level”:”0″,”ids_admin_include”:””,”ids_cookie”:””,”logger_link”:””,”log_ids_min”:”10″,”block_ids_min”:”30″,”email_ids_min”:”30″,”exception_fields”:”REQUEST.commentrnPOST.commentrnREQUEST.permalink_structurernPOST.permalink_structurernREQUEST.selectionrnPOST.selectionrnREQUEST.contentrnPOST.contentrnREQUEST.__utmzrnCOOKIE.__utmzrnREQUEST.s_persrnCOOKIE.s_persrnREQUEST.user_passrnPOST.user_passrnREQUEST.pass1rnPOST.pass1rnREQUEST.pass2rnPOST.pass2rnREQUEST.passwordrnPOST.passwordrnPOST.hide_my_wp.%rnREQUEST.hide_my_wp.%rnPOST.%import%rnREQUEST.%import%rnREQUEST.newcontentrnPOST.newcontentrnREQUEST.remember_%”,”ids_html_fields”:””,”separator4″:””,”trust_network”:”on”,”help_trust_network”:””,”enable_smwp_server”:””,”blocked_ips”:””,”blocked_ip_message”:”You are blocked. Please contact site administrator if you think there is a problem.”,”blocked_countries”:””,”replace1″:””,”auto_config_plugins”:””,”replace2″:””,”replace_in_html”:””,”db_ver”:”5.5.6″}

    #20560
    Suman Maharjan
    Post count: 8644

    Hi, you are using IIS server, so you’ll manually need to add HMWP rules in web.config file.

    Please check this FAQ for more details – https://codecanyon.net/item/hide-my-wp-amazing-security-plugin-for-wordpress/4177158/faqs/16072

    #20568
    victrim
    Post count: 3

    Thanks for the fast answer

    I also already tried to copy the ones in my web.config file but still no results. So I didn’t really understand jt.

    #20571
    victrim
    Post count: 3

    So if anybody can help me with it, should it be very nice.

    #20576
    Suman Maharjan
    Post count: 8644

    After adding HMWP rules to web.config file, restart IIS server.
    Also post here, web.config file (as text file) after adding HMWP rules to it.

    #20581
    victrim
    Post count: 3

    I got it working now. Only my recaptcha is invissible. Is there a way to get it back?

    #20590
    Suman Maharjan
    Post count: 8644

    Hi, please try these:

    – disable/uncheck “Directory List” option in General settings tab
    – disable/uncheck “Hide PHP Files” option in General settings tab
    – empty out “Ajax URL” field in Permalinks & URLs tab

    – if above doesn’t fix the issue then try disabling IDS option in IDS Firewall tab

    (please update HMWP rules in web.config file after applying above settings)

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.