Home Forums WordPress Plugins Hide My WP Entire Website Broken

This topic is: not resolved

This topic contains 11 replies, has 2 voices, and was last updated by  Suman Maharjan 3 months, 3 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #17024
    swagbox
    Post count: 9

    My entire website is currently broken. Tried installing and uninstalling the plugin, tried replacing the htcaccess and now all my hard work is lost. Please help!

    #17025
    swagbox
    Post count: 9

    Fixed, site back up but when I enable the plugin it breaks my site.

    #17026
    swagbox
    Post count: 9

    Problem now is that the hide my wp settings are stored somewhere and blocking me from reconfiguring the plugin once I re-activate.

    #17027
    swagbox
    Post count: 9

    Looks like this may solve it…

    Delete HMWP from DB, in “options” table, delete the rows with following option_name>
    – hide_my_wp
    – hide_my_wp_undo
    – hmwp_ids_installed
    – hmw_all_plugins
    – external_updates-hide_my_wp
    – hmwp_spam_counter
    – hmwp_temp_admin_path

    Note to developer: This is one of your most requested features… why not just make a script that people can run to fix this automatically?

    #17030
    swagbox
    Post count: 9
    This reply has been marked as private.
    #17037
    Suman Maharjan
    Post count: 7263

    Hi, please let us know your website’s wp-admin login details (as private reply), so that we can look into the issue further.

    #17039
    swagbox
    Post count: 9
    This reply has been marked as private.
    #17042
    Suman Maharjan
    Post count: 7263

    Hi, the re-write rules in the htaccess file doesn’t seem to be working! Can you please contact your hosting provider regarding why the re-write rules in htaccess file aren’t working?

    #17100
    swagbox
    Post count: 9

    I have updated to chmod 777. This is working now but when i apply even lite Hidemywp settings the entire site breaks (none of the css seems to load).

    Here is what I would like to do:
    + Restrict login on swagbox.io/wp-admin etc. and make the login page swagbox.io/login-admin
    + Change the theme name from Keysoft to Swagbox
    + Make it so the builtwith/ghostery don’t see that we are using wordpress.

    #17104
    Suman Maharjan
    Post count: 7263

    Hi, it seems like the web server you are using is Nginx. Can you please confirm this with hosting provider?

    If it’s Nginx server and WP single site, then please follow these steps:

    – in HMWP Start Tab, set “Medium Pripacy – More Compatibility” settings scheme and click on “Save Settings” button

    – In Start tab you should see Nginx Configuration button. If you don’t see this button, add &die_message=nginx to HMWP settings page URL to see Nginx rewrite rules. For example:
    http://yourdomain.com/wp-admin/options-general.php?page=hide_my_wp&die_message=nginx

    – Now add those lines (rewrite rules) to your Nginx configuration file. It’s usually located in /etc/nginx/nginx.conf or /etc/nginx/conf/nginx.conf or /etc/nginx/sites-available/domainname.com

    – restart nginx server

    Please let us know if it’s still the issue.

    #17125
    swagbox
    Post count: 9

    Followed directions but do not have nginx installed.

    I am on an amazon ec2 instance:
    https://aws.amazon.com/marketplace/pp/B00NN8Y43U

    #17136
    Suman Maharjan
    Post count: 7263
Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.