Home Forums WordPress Plugins Hide My WP HMWP doesn't work on translated domain

This topic is: not resolved

This topic contains 11 replies, has 2 voices, and was last updated by  Suman Maharjan 1 month ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #18256
    Strandhuis
    Post count: 9

    Hello Support,

    I have translated my website Strandhuisje.nl to a German version on Strandhuisje.de

    Then HMWP doesn’t work on the translated website for the URL’s of the picures.

    For example this picture: https://strandhuisje.nl/strandhuis-inhoud/uploads/2017/09/Strandhuisjes-Aan-Zee-Slapen-1-1024×683.jpg

    On the German site is the url not renamed by HMWP: https://strandhuisje.de/wp-content/uploads/2017/09/Strandhuisjes-Aan-Zee-Slapen-1-1024×683.jpg

    On an other website, which is translated with the same domain (strandhuisje.nu and German version on Strandhuisje.nu/de) HMWP works well.

    But with two domains (one for each language) HMWP does’t work.

    Do you know how to solve this?

    #18257
    Strandhuis
    Post count: 9

    I translated the site with WPML.

    #18272
    Suman Maharjan
    Post count: 7363

    Hi, please make sure you have added new name in “New upload path” field in Permalinks & URLs tab. If it’s still the issue then please try adding following replacement in “replace in html” option under replace tools tab:

    /wp-content/ ==> /strandhuis-inhoud/

    #18306
    Strandhuis
    Post count: 9

    Hello Suman,

    ‘New upload path’ was already filled in.

    The other option ‘replace in html’ didn’t work.

    Then you don’t see pictures on both sites (.nl and .de): https://s1.postimg.org/5wpybd2vu7/No_picture.jpg

    Now the upper pictures on the translate-site (.de) are not displayed. Other pictures on the .de site has url with ‘wp-content’ instead of ‘inhoud-strandhuis’. So, HMWP doesn’t work on the translate-site.

    I want a different domain for the translated site.

    I think it has something to de, because of the 2 different domains (.nl and .de), because as test I set the translation on Strandhuisje.nl/de instead of Strandhuisje.de and then HMWP works fine.

    #18307
    Strandhuis
    Post count: 9

    So, the problem still is:

    HMWP doesn’t work on the translate website (.de) for the URL’s of the picures.

    For example this picture: https://strandhuisje.nl/strandhuis-inhoud/uploads/2017/09/Strandhuisjes-Aan-Zee-Slapen-1-1024×683.jpg

    On the German site is the url not renamed by HMWP: https://strandhuisje.de/wp-content/uploads/2017/09/Strandhuisjes-Aan-Zee-Slapen-1-1024×683.jpg

    #18310
    Suman Maharjan
    Post count: 7363

    Hi, please let us know your site’s wp-admin login details as private reply so that we can look into this issue.

    #18393
    Strandhuis
    Post count: 9
    This reply has been marked as private.
    #18397
    Suman Maharjan
    Post count: 7363

    Hi, I tried to rename the Theme path in HMWP settings and got Internal Server error. You can rename “hide_my_wp” plugin folder in /wp-content/plugins/ directory to get rid of this error for now.
    And please let us know your site’s FTP details as private reply so that we can resolve it for you. Thanks!

    #18600
    Strandhuis
    Post count: 9
    This reply has been marked as private.
    #18603
    Suman Maharjan
    Post count: 7363
    This reply has been marked as private.
    #18690
    Strandhuis
    Post count: 9
    This reply has been marked as private.
    #18696
    Suman Maharjan
    Post count: 7363

    Can you please check now? I have added some replacements in “replace in html” option under Replace Tools tab.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.