Home Forums WordPress Plugins Hide My WP Login redirect to 404

This topic is: resolved

This topic contains 10 replies, has 3 voices, and was last updated by  MaT 1 month ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #19579
    Franck
    Post count: 7

    Redirect after login to 404 page

    Not able to login

    —–

    Hi! I have the exact same issue as those above, website url to connect is https://website.com/l?o=g, when I login it redirect me to https://website.com/l (404)
    The temporary fix I have is to rename the plugin (adding a letter), F5 (so I get connected), and rename the plugin back to have it working again..

    Could you please put the fix public so I could use it as well ?

    Best,

    • This topic was modified 3 months, 1 week ago by  Franck.
    #19581
    Franck
    Post count: 7

    BTW, other than that, plugin is working perfectly fine and I love it !

    #19582
    Suman Maharjan
    Post count: 8161

    Hi, can you please let us know the actual login URL?
    Also, generate debug report from HMWP start tab and post it here as private reply.

    #19583
    Franck
    Post count: 7
    This reply has been marked as private.
    #19585
    Suman Maharjan
    Post count: 8161

    Are you using any plugin other than HMWP that modifies WP login path? It seems like there’s some conflict. Also, did you also rename wp-admin path name in HMWP settings?
    Let us know your site’s wp-admin login details and FTP details (as private reply) so that we can look into the issue and fix it at the earliest for you.

    #19586
    Franck
    Post count: 7

    yes admin path name is now /admz
    there is no other plugin changing path

    wp-admin login details are available in my previous message as well. Can’t share this FTP sadly.

    #19598
    Suman Maharjan
    Post count: 8161

    Without FTP, I could not login to site’s backend.
    Can you please generate debug report from HMWP start tab and post it here as private reply?

    And if you have renamed wp-admin path name, then make sure that you have added following code in wp-config.php (before require_once(…)

    define(“ADMIN_COOKIE_PATH”, “/NEW_WPADMIN_PATH_NAME”);

    #19602
    Franck
    Post count: 7
    This reply has been marked as private.
    #19606
    Suman Maharjan
    Post count: 8161
    This reply has been marked as private.
    #19609
    Franck
    Post count: 7

    Worked ! I removed the “/” from the “Change login URL” and it now works like a charm
    Thanks Suman

    PS : would probably help futur users if there is no “/” in all the examples of the page : Change wp-login.php e.g. /login

    #20658
    MaT
    Active
    Post count: 18

    yes correct !!!

    change this in example without “/”
    i had 1:1 the same problem, cannot login anymore, only 404 error page and searched now over 1 hour to get it resolved with this topic here !

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.