Home Forums WordPress Plugins Hide My WP NGINX on Debian Server

This topic is: not resolved

This topic contains 29 replies, has 3 voices, and was last updated by  jhonny 7 months, 4 weeks ago.

Viewing 15 posts - 1 through 15 (of 30 total)
  • Author
    Posts
  • #21019
    jhonny
    Active
    Post count: 16

    Hello, after installing and activating the Plugin, the site design is broken and deconfigured.
    The site is hosted on the company “Digital Ocean” on a Debian 8.9 x64 server. Also, I use the NGINX and FastCGI cache.
    I tried following the tutorial, but it did not work.
    The lines are direrent on the Debian server.
    Can someone help me please?

    #21027
    Suman Maharjan
    Post count: 9626

    Hi, it’s most probably because you didn’t add HMWP rules in Nginx config file correctly. Did you follow this tutorial? – http://support.wpwave.com/videos/setup-hmwp-on-nginx-webserver

    Also, you’ll need to add HMWP rules within the ‘server’ block. Please post the Nginx config file (as text file) here.

    #21050
    jhonny
    Active
    Post count: 16

    I followed the Nginx setup tutorial, but it did not work. And also the lines of the files are different.
    On the ‘server’ block, I did not find the lines that show in the tutorial.
    See below the file “nginx.conf”.

    user www-data;
    worker_processes auto;
    worker_rlimit_nofile 100000;
    pid /run/nginx.pid;
    
    events {
    	worker_connections 4096;
    	multi_accept on;
    }
    
    http {
    	##
    	# EasyEngine Settings
    	##
    
    	sendfile on;
    	tcp_nopush on;
    	tcp_nodelay on;
    	keepalive_timeout 30;
    	types_hash_max_size 2048;
    
    	server_tokens off;
    	reset_timedout_connection on;
    	add_header X-Powered-By "EasyEngine 3.7.4";
    	add_header rt-Fastcgi-Cache $upstream_cache_status;
    
    	# Limit Request
    	limit_req_status 403;
    	limit_req_zone $binary_remote_addr zone=one:10m rate=1r/s;
    
    	# Proxy Settings
    	# set_real_ip_from	proxy-server-ip;
    	# real_ip_header	X-Forwarded-For;
    
    	fastcgi_read_timeout 300;
    	client_max_body_size 100m;
    
    	##
    	# SSL Settings
    	##
    
    	ssl_session_cache shared:SSL:20m;
    	ssl_session_timeout 10m;
    	ssl_prefer_server_ciphers on;
    	ssl_ciphers "EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH";
    	ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    	
    	##
    	# Basic Settings
    	##
    	# server_names_hash_bucket_size 64;
    	# server_name_in_redirect off;
    
    	include /etc/nginx/mime.types;
    	default_type application/octet-stream;
    
    	##
    	# Logging Settings
    	##
    
    	access_log /var/log/nginx/access.log;
    	error_log /var/log/nginx/error.log;
    
    	# Log format Settings
    	log_format rt_cache '$remote_addr $upstream_response_time $upstream_cache_status [$time_local] '
    	'$http_host "$request" $status $body_bytes_sent '
    	'"$http_referer" "$http_user_agent"';
    
    	##
    	# Gzip Settings
    	##
    
    	gzip on;
    	gzip_disable "msie6";
    
    	gzip_vary on;
    	gzip_proxied any;
    	gzip_comp_level 6;
    	gzip_buffers 16 8k;
    	gzip_http_version 1.1;
    	gzip_types
    	    application/atom+xml
    	    application/javascript
    	    application/json
    	    application/rss+xml
    	    application/vnd.ms-fontobject
    	    application/x-font-ttf
    	    application/x-web-app-manifest+json
    	    application/xhtml+xml
    	    application/xml
    	    font/opentype
    	    image/svg+xml
    	    image/x-icon
    	    text/css
    	    text/plain
    	    text/x-component
    	    text/xml
    	    text/javascript;
    
    	##
    	# Virtual Host Configs
    	##
    
    	include /etc/nginx/conf.d/*.conf;
    	include /etc/nginx/sites-enabled/*;
    }
    
    #mail {
    #	# See sample authentication script at:
    #	# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
    #
    #	# auth_http localhost/auth.php;
    #	# pop3_capabilities "TOP" "USER";
    #	# imap_capabilities "IMAP4rev1" "UIDPLUS";
    #
    #	server {
    #		listen     localhost:110;
    #		protocol   pop3;
    #		proxy      on;
    #	}
    #
    #	server {
    #		listen     localhost:143;
    #		protocol   imap;
    #		proxy      on;
    #	}
    #}
    
    Attachments:
    You must be logged in to view attached files.
    #21056
    Suman Maharjan
    Post count: 9626

    The atached Nginx config doesn’t have server block in it, but at the end there are 2 includes:

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*

    So, most probably the required nginx config file is within directory /etc/nginx/sites-enabled/ or /etc/nginx/conf.d/
    Please check

    #21057
    jhonny
    Active
    Post count: 16

    Sorry, I did not understand the first part of the answer. Should I include these two lines at the end of the file (nginx.conf)?
    About the directories, I also can not find, please see attached prints.

    Attachments:
    You must be logged in to view attached files.
    #21062
    Suman Maharjan
    Post count: 9626

    No, those 2 lines are already there in nginx config file. Hence, I wanted you to check for other nginx config file within those 2 directories.
    Please ask your hosting provider regarding the correct nginx config file (location) for your website.
    Also, can you please let us know your site’s URL?

    #21070
    jhonny
    Active
    Post count: 16

    I do not use shared hosting. I use a server on Digital Ocean, they will not support me on this issue.
    I used EasyEngine to install Nginx.
    If I give you my password, do you find the files for me, please?
    I have urgency on this site.

    #21086
    Suman Maharjan
    Post count: 9626

    Alright, do let us know your server credentials so that we can look into it for you.

    #21088
    jhonny
    Active
    Post count: 16
    This reply has been marked as private.
    #21100
    Suman Maharjan
    Post count: 9626
    This reply has been marked as private.
    #21108
    jhonny
    Active
    Post count: 16
    This reply has been marked as private.
    #21111
    Suman Maharjan
    Post count: 9626
    This reply has been marked as private.
    #21114
    jhonny
    Active
    Post count: 16
    This reply has been marked as private.
    #21116
    Suman Maharjan
    Post count: 9626

    If you are not able to open file via FTP then it should not be related to HMWP plugin. You can confirm it by simply disabling the plugin.

    Note: To get back plugin’s previous settings, you’ll need to click on “undo previous settings” button in HMWP start tab.

    #21123
    jhonny
    Active
    Post count: 16

    I am no longer able to edit files via FTP.

    But the plugin worked.

    Thank you very much for the help. 🙂

Viewing 15 posts - 1 through 15 (of 30 total)

You must be logged in to reply to this topic.