Home Forums WordPress Plugins Hide My WP Not able to access the admin after changing wp-login.php on Localhost!

This topic is: not resolved

This topic contains 30 replies, has 2 voices, and was last updated by  Suman Maharjan 3 months ago.

Viewing 15 posts - 1 through 15 (of 31 total)
  • Author
    Posts
  • #21415
    michelmany
    Active
    Post count: 24

    Hi. After changing wp-login.php to /painel I’m not able to access the admin anymore. I getting a 404 error. I’m testing it from localhost. Can you help me? Thanks!

    #21418
    Suman Maharjan
    Post count: 8927

    Hi, it should be “painel” without backslash “/”

    If you have applied one of the pre-made settings, then you should also be able to login with http://www.YourDomain.com/wp-login.php?hide_my_wp=1234
    If you can’t still login, then rename “hide_my_wp” plugin folder in “/wp-content/plugins/” directory and the login. After logging in, rename back “hide_my_wp” plugin folder to it’s original name. You can now re-apply the settings.

    #21419
    michelmany
    Active
    Post count: 24

    Thanks for the quick reply.

    I have change it to “painel” without backslash and got the same.

    I’m attaching two screenshots to help you to see what I’ve done so far.

    Does it work on Multisite and localhost?

    Thanks again!

    Attachments:
    You must be logged in to view attached files.
    #21423
    Suman Maharjan
    Post count: 8927

    Can you please generate debug report from HMWP start tab and post it here as private reply? Are you using any other plugin or theme that modifies login url?

    It works fine with WP Multisite on Apache Server.

    #21425
    michelmany
    Active
    Post count: 24
    This reply has been marked as private.
    #21431
    Suman Maharjan
    Post count: 8927

    What if you do not rename wp-login.php name? Aren’t you able to access the backend with http://www.YourDomian.com/wp-login.php?HMWP_Secret_key

    “not available for sub-directory multisite”
    >> If it’s WP Multisite then renaming wp-admin path option is available only in sub-domain multisite, but not for sub-directory multisite.

    Regarding the error, in HMWP there is a security check to make sure that wordpress secret keys (in wp-config.php) are valid and secure. More info regarding security keys here – https://www.wpwhitesecurity.com/wordpress-tutorial/wordpress-security-keys/

    And security keys can be generated from here – https://api.wordpress.org/secret-key/1.1/salt/

    #21438
    michelmany
    Active
    Post count: 24

    Hey Suman,

    If I do not rename wp-login.php, it works normally getting access to the dashboard using http://www.mysite.com/wp-admin or even http://www.mysite.com/my-client/wp-admin. Actually, I bought this plugin to rename the admin access to something like http://www.mysite.com/painel and http://www.mysite.com/my-client/painel.
    If this approach is not possible with this plugin, unfortunately, I won’t need this plugin and I’ll need my money back.

    Regarding the error on activating the plugin, I mean there’s a php error, please check my screenshot attached!

    Thank you for your help.

    • This reply was modified 3 months, 2 weeks ago by  michelmany.
    • This reply was modified 3 months, 2 weeks ago by  michelmany.
    Attachments:
    You must be logged in to view attached files.
    #21444
    Suman Maharjan
    Post count: 8927

    Actually, renaming default wp login path should work. But as you are setting it up in localhost we are not able to look much into the site. May be you can try it in live environment (where we can help you set it up). If still the issue renaming login path, then we would be happy to make a full refund.

    #21445
    michelmany
    Active
    Post count: 24

    Sure.
    I’m finishing up some development then I’ll try to use the plugin in a live environment. I’ll let you know!
    Thanks again!

    Michel Moraes

    • This reply was modified 3 months, 2 weeks ago by  michelmany.
    #21447
    Suman Maharjan
    Post count: 8927

    Alright! Thanks for your understanding.

    #21496
    michelmany
    Active
    Post count: 24
    This reply has been marked as private.
    #21512
    Suman Maharjan
    Post count: 8927

    Hi, can you please let us know your site’s wp-admin login details and FTP details as private reply so that we can look into the issue further. Thanks!

    #21513
    michelmany
    Active
    Post count: 24
    This reply has been marked as private.
    #21518
    Suman Maharjan
    Post count: 8927
    This reply has been marked as private.
    #21520
    michelmany
    Active
    Post count: 24
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 31 total)

You must be logged in to reply to this topic.