Home Forums WordPress Plugins Hide My WP Not working with WP Rocket

This topic is: not resolved

This topic contains 25 replies, has 3 voices, and was last updated by  Suman Maharjan 1 month, 1 week ago.

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • #17207
    beeriz
    Active
    Post count: 21

    Hello.
    Its been 2 months and I still wasn’t able to make your script work, its not working with WP Rocket, and I’m not going to disable it for WP HIDE.

    Any time I use even this minimal config (see next reply), website freeze, and when I restart nginx, I get 404 on all files.

    #17208
    beeriz
    Active
    Post count: 21
    This reply has been marked as private.
    #17210
    beeriz
    Active
    Post count: 21
    This reply has been marked as private.
    #17215
    Suman Maharjan
    Post count: 7142

    Hi, HMWP is compatible with WP Rocket. Did you configure the plugin correctly?
    You’ll need to follow these steps (Nginx + WP single site):

    – in HMWP Start Tab, set “Medium Pripacy – More Compatibility” settings scheme and click on “Save Settings” button

    – In Start tab you should see Nginx Configuration button. If you don’t see this button, try accessing directly, the URL – http://YourDomain.com/wp-admin/options-general.php?page=hide_my_wp&die_message=nginx

    – Now add those lines (rewrite rules) to your Nginx configuration file. It’s usually located in /etc/nginx/nginx.conf or /etc/nginx/conf/nginx.conf or /etc/nginx/sites-available/domainname.com
    (add the rules within server block)

    – restart nginx server

    Please let us know if it’s still the issue.

    #17219
    beeriz
    Active
    Post count: 21
    This reply has been marked as private.
    #17221
    fbsena
    Pro
    Post count: 36

    I use the wp rocket plugin with hmwp in the (medium privacy) option and everything works fine.
    There may be an error in the nginx configuration.

    #17222
    beeriz
    Active
    Post count: 21

    Show us in private the website you’re referring to?
    Thanks

    #17225
    Suman Maharjan
    Post count: 7142

    Hi beeriz, can you please post here your Nginx configuration file before and after adding HMWP rules in it? Please post as text files. Thanks!

    #17571
    beeriz
    Active
    Post count: 21
    This reply has been marked as private.
    #17579
    Suman Maharjan
    Post count: 7142

    Hi, it seems like HMWP is currently disabled in https://bnin.org
    Can you please apply “medium privacy more compatibility” settings scheme in HMWP, update nginx config file with HMWP rules and restart Nginx server.
    If it’s still the issue then please let us know your site’s wp-admin login details as private reply (do not remove HMWP rules from nginx config file).

    #17582
    beeriz
    Active
    Post count: 21
    This reply has been marked as private.
    #17589
    Suman Maharjan
    Post count: 7142

    You can disable HMWP plugin and then let us know your site’s wp-admin login details as private reply, so that we can activate and check. But do not remove HMWP rules from nginx config file.

    #17590
    beeriz
    Active
    Post count: 21
    This reply has been marked as private.
    #17591
    beeriz
    Active
    Post count: 21
    This reply has been marked as private.
    #17594
    beeriz
    Active
    Post count: 21

    It is crashing out server like crazy!
    Just having the plugin activated is causing tons of errors. Any lead?

Viewing 15 posts - 1 through 15 (of 26 total)

You must be logged in to reply to this topic.