Home Forums WordPress Plugins Hide My WP Prevent plugin to use RewriteBase / in .htaccess

This topic is: not resolved

This topic contains 7 replies, has 2 voices, and was last updated by  Suman Maharjan 1 week, 1 day ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #22861
    zir787
    Post count: 9

    Hi,

    Need Help From Preventing RewriteBase / used in .htaccess as I have additional commands in .htaccess which are not working once the RewriteBase / is removed from the code in .htaccess it starts functioning normally.

    Regards,
    Zir

    #22863
    Suman Maharjan
    Post count: 8927

    Hi, please post here your site’s htaccess content (as text file) –

    1) before applying HMWP settings
    2) after applying HMWP settings

    #22878
    zir787
    Post count: 9

    Hi Suman,

    Please find the requested information below.

    After research I have found that rewritebase / is creating problem with the subfolder I have created within the home directory (public_html) where the wordpress is installed.

    Regards,

    • This reply was modified 1 week, 2 days ago by  zir787.
    Attachments:
    You must be logged in to view attached files.
    #22882
    Suman Maharjan
    Post count: 8927

    If the subfolder name is “abcxyz” then it should be actually – RewriteBase /abcxyz/
    Please try changing the RewriteBase as above and let us know.

    #22889
    zir787
    Post count: 9

    I can update it but the problem is, hide my wordpress will rewrite the .htaccess having the folder name removed.

    I need a permanent solution where hide my wordpress does not keep playing with the subfolder of the public_html except for the wordpress installation.

    edit: I did do what you suggested and it worked until I loaded my wordpress site and now again I have lost the settings into my .htaccess

    Please advise how do I stop hide my wordpress to stop making changes to .htaccess over and over again or put an exception of the subfolder in hide my wordpress settings?

    Regards,
    Zir

    • This reply was modified 1 week, 2 days ago by  zir787.
    #22898
    Suman Maharjan
    Post count: 8927

    In that case please enable “customized htaccess” option in General Settings tab (this will disable auto update of htaccess file by HMWP). You then need to click on ‘Manual Configuration’ button in General Settings tab and add HMWP rules manually in htaccess file.

    #22901
    zir787
    Post count: 9

    Hi Suman,

    Thanks for the update I have tried that steps as suggested and so far have not seen a problem occurring again.
    One last thing I wanted to know is how do I hide wordpress words from my wordpress site? Earlier I remember there was a check box that I used to click and the settings use to apply.

    Regards,
    Zir

    #22904
    Suman Maharjan
    Post count: 8927

    What exactly do you want to hide? Make sure that you check the site in logged out state.
    You can use “replace in html” option under Replace Tools tab to replace the text/comments in the site’s page source.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.