Home Forums WordPress Plugins Hide My WP Broken site

This topic is: not resolved
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29246
    Irvintz
    Post count: 1

    Hello,

    I just installed the plugin (on NGINX) and also running the beaver builder plugin for the site builder. The site’s design gets messed up when the plugin is activated. It works as far as changing what can be seen in the source code.

    The server modification code has not been added yet. I’ve provided the code to my hosting provider and I’m still waiting for them to add the code.

    Is the site breaking because the code has not been added to mod the NGINX settings?

    Is a new code generated every time the plugin is activated?

    #29251
    Suman M.
    Post count: 11593

    Hi, yes, the site is breaking because the HMWP rules have not been added to site’s Nginx config file.
    A new set of rules will be generated only when you change the settings in Permalinks Tab, and when you do so the rules needs to be updated in Nginx config too.

    #29264
    Irvintz
    Post count: 1
    This reply has been marked as private.
    #29273
    Suman M.
    Post count: 11593

    It’s needed to add the rules in the site’s Nginx config file (within server{} block) and restart nginx. Can’t we have direct access to the Nginx config? If not, then can you ask your hosting provider to send you the Nginx config file so that we can tell where exactly to put the rules. Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.