Home Forums WordPress Plugins Hide My WP contact form 7 issue

This topic is: not resolved

This topic contains 4 replies, has 2 voices, and was last updated by  Suman M. 1 week, 2 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #25454
    marnixhoh
    Post count: 4

    Dear customer support,
    I am having a very strange issue. Contact form 7 still works and sends emails as expected, but when a user is not logged in, the confirmation “email sent successfully” never shows up. When the user is logged in, it does. The problem appears to be related to the non-logged in user not having access to the rest api since I get the following errors in my console:

    /rest/contact-form-7/v1/contact-forms/27/refill:1 Failed to load resource: the server responded with a status of 404 ()
    /rest/contact-form-7/v1/contact-forms/27/feedback:1 Failed to load resource: the server responded with a status of 404 ()

    Again, when the user is logged in, everything works fine and these errors do not show up.
    Any idea what might be causing the problem here?

    Thank you so much for your help!

    • This topic was modified 1 week, 6 days ago by  marnixhoh.
    #25456
    marnixhoh
    Post count: 4

    Also, I renamed ‘wp-json’ to ‘rest’ using HideMyWP, that’s why the urls in the error messages start with ‘rest’

    #25470
    Suman M.
    Post count: 9911

    Hi, can you please try emptying out “API base” and “API query” fields in Permalinks & Urls tab?

    If it’s still the issue then please do these:
    – disable “Anti Spam” option in HMWP General settings tab
    – enter your name and email address in “Email sender name” and “Email sender address” fields in General settings tab
    – if still the issue then try disabling “IDS” option in IDS Firewall tab

    Let us know!

    #25487
    marnixhoh
    Post count: 4

    Hey Suman,
    Thanks for your help! emptying out ‘API base’ and ‘API query’ solved the issue. Could you have a look at the issue though? I would like to chanage the name from wp-json to something else like ‘rest’. Seems like there is some sort of bug.

    Thanks again for the support! 🙂

    #25503
    Suman M.
    Post count: 9911

    Hi, some themes/plugins look for default wp-json path. So in that case renaming the paths might cause the issue. In such case we recommend you to disable renaming it. Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.