Home Forums WordPress Plugins Hide My WP Hide Zencache static folder

This topic is: resolved
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #8119
    kvogel
    Post count: 10

    Hi,
    I using Zencache. Zencache create folder in WP-CONTENT. example: mysite.com/wp-content/zencache/cache
    I try to change this folder and move to site root. But this folder structure hard coded in zencache php code.

    All static cahce and minfied files come from http://mysite.com/wp-content/zencache…
    All other url are changed and hidden by HMWP.
    I think HMWP can’t change cached content folder.

    My question:
    How can I add outbound rewrite rule to IIS? I want to cahnge all “wp-content/zencache/*” to “static-cache/*”

    Please help me.

    Thanks.

    Kristof

    #8131
    Suman M.
    Post count: 12463

    Hi, in permalinks & urls tab set “New wp-content path” field to something like “inc”

    In “replace in html” option under replace tools tab, add the following replacement:

    wp-content/ ==> inc/

    #8142
    kvogel
    Post count: 10

    Hi Suman,

    It’s not working.
    Zencache is a last module in HTTP content delivery.
    Hyde My WP not affect this last content.
    My site is: http://portya.net

    Example:
    “wp-content/scouting-speed/htmlc/public/portya-net/0/c/e/a/2/e5bae3820155eabf8a382f233cd2ed14-compressor-part.js”

    Please find in source code this cache folder:”scouting-speed”

    I have to add URL rewrite rule on OUTBOUND in IIS web server.
    How to add wp-content/ ==> inc/ outbound rule?

    thanks, Kristof

    #8150
    Suman M.
    Post count: 12463

    You don’t need to add wp-content/ ==> inc/ in IIS config. Goto HMWP Replace tools tab, and add it in “replace in html” option boxes.

    #8153
    kvogel
    Post count: 10

    Yes, I understand, I added, but it’s not effective.

    [WORDPRESS] -> [HMWP] -> [ZENCACHE] -> [FRONTEND USER]

    #8169
    Suman M.
    Post count: 12463

    Hi, please let us know your website’s wp-admin login details (as private reply), so that we can have a look at the issue further.

    #8177
    kvogel
    Post count: 10

    Hi,
    I find solution.

    I add this outbound rule to web.config

    <outboundRules>
    <rule name=”Rewrite cache folder” preCondition=”IsHTML” patternSyntax=”ECMAScript”>
    <match filterByTags=”A, Img, Link, Script” pattern=”http://(eu-cdn.)?(portya.net)/(wp-content)/(.*)” />
    <action type=”Rewrite” value=”http://{R:1}{R:2}/inc/{R:4}” />
    </rule>
    <preConditions>
    <preCondition name=”IsHTML”>
    <add input=”{RESPONSE_CONTENT_TYPE}” pattern=”^text/html” />
    </preCondition>
    </preConditions>
    </outboundRules>

    Thanks,

    Kristof

    #8188
    Suman M.
    Post count: 12463

    That’s awesome!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.