Home Forums WordPress Plugins Hide My WP Javascript errors

This topic is: not resolved
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #30447
    Legrandkaba
    Active
    Post count: 15

    Hi Support,

    Hide my WP has caused issue to my website. I first thought that the issue was related to the theme itself.

    Therefore, I opened a support ticket to the theme maker to check the issue with the site. The issue was that the search function of the site was not responding normally, and also it was impossible to submit new property.

    After checking the issue, the theme support found that the issue is related to Hide My WP plugin and they deactivated it.

    Here is what the theme maker support wrote me regarding your plugin:

    WP Hide Plugin create javascript error on the console, probably some of its settings need to be changed to make it works correctly.

    The site is working normally now without the Hide my WP plugin activated,

    But I really want to continue using it. I use Hide My WP on almost all my websites because I found it very important for the site security.

    The login URL I was using is: https://selogerenguinee.com/nouvelleconnexion

    Could you please check the issue for me.

    With kind regards,

    #30453
    Suman M.
    Post count: 12179

    Hi, thanks for reaching out to us. I’ve configured HMWP plugin in your site now and it seems to be working fine. Can you please check and let us know? If any issue, let us know the steps to check that issue.

    Regards!

    #30569
    Legrandkaba
    Active
    Post count: 15

    Hi,

    Thank you a lot for your attention on this matter.

    The Javascript issue is now resolved as it is now possible to submit property.

    There are two other issues I am currently facing.

    1.The social login (Facebook and Gmail) are not working despite been correctly configured.
    It is only to allow users to be able to register and submit property using their Facebook or Gmail accounts.
    When you want to login using Facebook or Gmail, it reports an 404 error that the page does not exist.

    2. The name of theme is still visible when one inspect the files. I wondering if it possible to hide the name Myhome of the theme, and replace it with Seloger en Guinée or anything else.

    Thank you.

    With kind regards,

    #30571
    Suman M.
    Post count: 12179

    Good to know that it’s working now.

    1) I have disabled/unchecked “Directory List” and “Hide PHP Files” options in HMWP Hiding tab. Can you please check if social login is working now?

    2) I have replaced word “myhome” in stylesheet IDs. But “myhome” is being used in CSS class names too and it’s not recommended to hide/rename css class names as it might break the site.

    Please check and let us know.

    #30581
    Legrandkaba
    Active
    Post count: 15

    Hi,

    Thank you so much for your help.

    The social login is still not working. It keeps on reporting a 404 error one you try to connect with either Facebook or Gmail.

    Please see attached screenshots of the error reported.

    With kind regards,

    Attachments:
    You must be logged in to view attached files.
    #30583
    Suman M.
    Post count: 12179

    Hi, can you please check now? I had to add replacement in Replace in HTML section.

    #30593
    Legrandkaba
    Active
    Post count: 15

    Hi,

    Thank you for your email.

    Unfortunately, it is still not fully working. There are some changes now as the social login works partially.
    If you click on either Facebook or Gmail login, it takes you now to the page where you have to enter your credentials to login.
    But, when you enter you credentials, the error 404 page not fount is reported.

    Before you made the replacement in HTML section, when one clicks on login, it reports directly the errr0r 404. But now, it takes you to the login screen, but you are not able to login due the mentioned error.

    With kind regards,

    #30595
    Suman M.
    Post count: 12179

    It’s because of the way this social login works. It calls to https://yourdomain.com/wp-admin/admin-post.php but we have set to hide wp-admin in HMWP and hence it will be blocked. I’ve disabled “Hide wp-admin folder” in HMWP Hiding tab and social login is now working. Please check.

    • This reply was modified 1 week, 5 days ago by Suman M..
    #30603
    Legrandkaba
    Active
    Post count: 15

    Hi,

    Thank you so much for your help.

    I have checked and it works normally now, both Facebook and Gmail.

    I would like to know if the fact of disabling “Hide wp-admin folder” in HMWP Hiding tab, would not affect the security of the site.

    With kind regards,

    #30607
    Suman M.
    Post count: 12179
    This reply has been marked as private.
    #30684
    Legrandkaba
    Active
    Post count: 15
    This reply has been marked as private.
    #30694
    Suman M.
    Post count: 12179
    This reply has been marked as private.
Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.