Home Forums WordPress Plugins Hide My WP PHP Fatal error

This topic is: resolved
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #86
    oldfarty
    Post count: 4

    Hi, thanks for this plugin.
    I was wondering what this error is all about?
    PHP Fatal error: Undefined class constant ‘slug’ in xxxxx/wp-content/plugins/hide_my_wp/lib/class.helper.php on line 190

    This is an error that is constant and it is in version 2.01.
    It is showing in my error_log and it’s current.

    Thanks again

    • This topic was modified 7 years, 8 months ago by oldfarty.
    #89
    Hassan
    Post count: 955

    Hi,

    It seems you enabled multi-site incompletely or use a very old setup. Please check your wp-config file and make sure you have following lines:

    define( ‘SITE_ID_CURRENT_SITE’, 1);
    define( ‘BLOG_ID_CURRENT_SITE’, 1);

    If you couldn’t find them simply add those lines after define(‘MULTISITE’, true);.

    Please let me know your current WP version plus the version that you first enabled MU. (e.g. current version 3.6 and enabled MU in 3.4)

    • This reply was modified 7 years, 8 months ago by Hassan.
    #90
    oldfarty
    Post count: 4

    I use Multisite almost exclusively and have been since version 3.1.3.
    The lines:
    define( ‘SITE_ID_CURRENT_SITE’, 1);
    define( ‘BLOG_ID_CURRENT_SITE’, 1);
    are there.

    I fresh installed the site with 3.6 beta4 on June 26, 2013 and I now have 3.6.1.

    I know how to install Multisite, thanks for asking.

    #100
    Hassan
    Post count: 955

    You’re right! It was not a multi-site issue. I just fixed it 🙂

    The fixed file was attached. (Change .txt to .php)

    PS:
    If you could wait for few hours you can test v2.1 beta.

    Attachments:
    You must be logged in to view attached files.
    #103
    oldfarty
    Post count: 4

    Thanks Hassan, I believe that resolved this issue.
    Much appreciated. 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.