Home Forums Prestashop Modules SEO Friendly URLs Prestashop SEO Friendly (Pretty) URL product id dont work (havent changed)

This topic is: resolved
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #18782
    isfata
    Active
    Post count: 12

    I’ve installed module correctly, but when I checked it on navigation, I’ve seen that products in their URL’s still have id’s. I’ve checked module options and they said that Product ID’s will be removed.

    Please help.

    #18858
    Vikas Singhal
    Post count: 219

    Sorry about the delay, we have seen your review about our plugin. I will work on this problem and assure you a solution by the end of the day.

    #18871
    isfata
    Active
    Post count: 12

    What about the solution? Did you find the way?

    #18883
    Vikas Singhal
    Post count: 219

    I see that you have disabled friendly URL in the shop, is there a reason for that? My module won’t work without that, no SEO related module will work in this situation.

    #18887
    isfata
    Active
    Post count: 12

    I’ve disabled it temporarily cause it wasn’t working with it enabled. You have backoffice login dont you?

    #18896
    isfata
    Active
    Post count: 12

    Please could you help me to solve the problem, I’ve enabled friendly urls, take a look. I paid money for your plugin could I get any advice at least?

    #18897
    Vikas Singhal
    Post count: 219

    I am working on it. Please wait.

    #18899
    isfata
    Active
    Post count: 12

    Other products display url fine. But there is product with variation which struggles (both in EN and LT):

    http://medgaminiai.lt/lt/medine-dezute-m1.html#/28-mediena-berzas/32-stilius-iprastas
    http://medgaminiai.lt/en/wood-pill-box-m1.html#/28-wood-birch/32-style_design-plain

    and when trying to change the style, variations (EN and LT) it switches back to default style instantly (seo friendly urls disabled – problem goes away)

    And english category page does ok, but lithuanian language category page struggles:

    http://medgaminiai.lt/lt/category/formos%20?rewrite=formos
    (and displays page error)

    English does perfectly: http://medgaminiai.lt/en/category/boxes-containers

    • This reply was modified 2 years, 11 months ago by isfata.
    • This reply was modified 2 years, 11 months ago by isfata.
    #18907
    Vikas Singhal
    Post count: 219

    I am checking this now. Sorry about the delay in response its due to the time zone difference. I am in India (+5.30GMT).

    #18910
    Vikas Singhal
    Post count: 219

    I confirm all the problems you said, please send me the FTP login so that I can apply the fixes.

    #18911
    Vikas Singhal
    Post count: 219

    I have identified the solution to both the problems.

    1 – It was bug with the module, I have identify and fixed it. The style (attribute) is appended to the URL now and changing style also works fine. I have uploaded the module to the store.

    2 – Category problem is due to a trailing space in your “lt” categories friendly url settings. I have remove space from this – http://medgaminiai.lt/lt/category/dezutes and it works fine. Please remove all the space in friendly URLs for lithuanian for all the categories.

    Hope this helps you and motivate you to change your rating 🙂

    • This reply was modified 2 years, 11 months ago by Vikas Singhal.
    #18942
    Vikas Singhal
    Post count: 219

    If everything is going well, can you please edit your review about my product?

    #18943
    isfata
    Active
    Post count: 12

    It’s not going well, I dont know why. Problems:

    For products with variations ID’s are still there:
    http://medgaminiai.lt/lt/dezutes/47-medine-dezute-m1.html#/28-mediena-berzas/32-stilius-iprastas

    Lithuanian version category link for specialties doesnt work:
    http://medgaminiai.lt/lt/category/formos%20?rewrite=formos
    While english version works:
    http://medgaminiai.lt/en/category/specialties

    Some products are not opening at all in LT: (wood bead K2)
    http://medgaminiai.lt/lt/karoliukai%20/medinis-laso-karoliukas-k2.html
    But in english it works: http://medgaminiai.lt/en/beads/wood-round-waterdrop-bead-k2.html

    #18944
    isfata
    Active
    Post count: 12

    I’ll turn off friendly urls, cause I want shop working at least with terrible url’s. But If you will find a fix, you have my shop backend admin entry so you can turn it on and apply changes. I’ll wait for your response.

    #18959
    Vikas Singhal
    Post count: 219

    I have gone ahead and enabled friendly URL again.

    1 – Its not possible to remove variation ID as its required by Prestashop. Please raise a refund request if this is a show stopper for you.

    2 – I have removed spaces (as pointed earlier) in category’s friendly URLs in “li” language and they are working fine.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.