Home Forums WordPress Plugins Hide My WP Problem with PHP 7.2.13 and Debian 9

This topic is: not resolved

This topic contains 11 replies, has 2 voices, and was last updated by  Suman M. 4 months, 4 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #24940
    holly303
    Active
    Post count: 11

    Hi,

    here is my support request. I should open a ticket here. This was written to me by namus25 at Envarto.When I did an import I got this error message (WordPress debug mode:

    Deprecated: Function create_function() is deprecated in /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/init.php on line 147

    Deprecated: Function create_function() is deprecated in /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/init.php on line 536

    The next issue is, if I activate the IDS and I want to log me in with my specific URL, I get this error message. I had no problems with PHP 5.6 only with my new webspace with PHP 7.2.13.

    Fatal error: Uncaught Exception: SimpleXML not loaded. in /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/lib/mute-screamer/libraries/IDS/Filter/Storage.php:272 Stack trace: #0 /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/lib/mute-screamer/libraries/IDS/Filter/Storage.php(111): IDS_Filter_Storage->getFilterFromXML() #1 /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/lib/mute-screamer/libraries/IDS/Monitor.php(189): IDS_Filter_Storage->__construct(Object(IDS_Init)) #2 /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/lib/mute-screamer/mute-screamer.php(402): IDS_Monitor->__construct(Array, Object(IDS_Init)) #3 /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/lib/mute-screamer/mute-screamer.php(225): HMWP_MS_IDS->run() #4 /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/lib/mute-screamer/mute-screamer.php(1098): HMWP_MS_IDS->__construct() #5 /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/load.php(162): include_once(‘/var/www/web35/…’) #6 /var/www/web35/htdocs/neu/wp- in /var/www/web35/htdocs/neu/wp-content/plugins/hide_my_wp/lib/mute-screamer/libraries/IDS/Filter/Storage.php on line 272

    Could you help me, please?

    Regards

    Holly

    #24942
    Suman M.
    Post count: 10323

    Hi, deprecated function alert is not disabled in your PHP installation. It’s recommended to disable deprecated function alert and notices.
    Also, it seems like SimpleXML is disabled in your PHP 7 installations.

    Please contact you hosting provider and ask them to enable SimpleXML, and turn off deprecated function alert.

    #24944
    holly303
    Active
    Post count: 11

    Hi again,

    the same issue like before. I get a blank login page, if I enable the IDS.
    simpleXML is installed and active.

    Regards

    Holly

    #24946
    Suman M.
    Post count: 10323

    The login page is simply blank or you get any error message there? Can you please try setting “Block Threshold” value to 30 or 40 in HMWP IDS Firewall tab? Let us know the result.

    #24959
    holly303
    Active
    Post count: 11

    Hi,

    I have a blank Page without an error message. I will activate the debug mode again ..

    Regards

    Holly

    #24963
    Suman M.
    Post count: 10323

    Hi, did you also try setting Block Threshold value to 30 or 40? Let us know.

    #25036
    holly303
    Active
    Post count: 11

    Hi,

    now I am back. Where can I find the settings?

    Regards

    #25046
    Suman M.
    Post count: 10323

    Do you mean HMWP settings? It’s under “Settings” menu – https://www.screencast.com/t/hXWwvVys

    #25125
    holly303
    Active
    Post count: 11

    No the setting to

    Hi, did you also try setting Block Threshold value to 30 or 40? Let us know.

    • This reply was modified 5 months, 1 week ago by  holly303.
    • This reply was modified 5 months, 1 week ago by  holly303.
    #25133
    Suman M.
    Post count: 10323

    Please check the screenshot – https://www.screencast.com/t/VxdX8WD5GAs

    #25180
    holly303
    Active
    Post count: 11

    Hi, it doesn’t work. I have tried different settings.

    #25196
    Suman M.
    Post count: 10323

    Did you also try disabling IDS option under IDS Firewall tab? If it’s still the issue then please let us know your site’s wp-admin login details as private reply so that we can look into it further.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.