Home Forums WordPress Plugins Hide My WP Webpage doesn't seem to load .css files

This topic is: not resolved
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #29
    adamxerxes
    Post count: 12

    Hi!
    I just purchased Hide My WP from you and i seem struggle a bit with loading css files although i have followed the included instructions and also checked the .htaccess file that it looks good.

    Here is the .htacces file content

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteRule ^modules/aa405a34/(.*) /wp-content/plugins/akismet/$1 [QSA,L]
    RewriteRule ^modules/993113a5/(.*) /wp-content/plugins/aqua-page-builder/$1 [QSA,L]
    RewriteRule ^modules/ff957fea/(.*) /wp-content/plugins/contact-form-7/$1 [QSA,L]
    RewriteRule ^modules/29f175ba/(.*) /wp-content/plugins/meta-box/$1 [QSA,L]
    RewriteRule ^library/(.*) /wp-includes/$1 [QSA,L]
    RewriteRule ^file/(.*) /wp-content/uploads/$1 [QSA,L]
    RewriteRule ^modules/(.*) /wp-content/plugins/$1 [QSA,L]
    RewriteRule ^template/template/main\.css /?style_wrapper=1 [QSA,L]
    RewriteRule ^template/(.*) /wp-content/themes/cacoon/$1 [QSA,L]
    RewriteRule ^my_ajax\.php /wp-admin/admin-ajax.php [QSA,L]
    RewriteRule ^user_submit\.php /wp-comments-post.php [QSA,L]
    RewriteRule ^wp-content/themes/cacoon/screenshot\.png|readme\.html|license\.txt|wp-content/debug\.log|wp-includes/$ /nothing_404_404 [QSA,L]
    RewriteRule ^(index\.php|wp-content/repair\.php|wp-comments-post\.php|wp-includes/js/tinymce/wp-tinymce\.php|xmlrpc\.php|wp-login\.php|index\.php|wp-admin/)(.*) $1$2 [QSA,L]
    RewriteRule ^(.*)\.php$ /nothing_404_404 [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    In my Permalink settings i have set “New style name” to “/template/main.css”
    I’m really not sure what makes this, but i have tried to edit the .htaccess file manually and then remove the 777 permission, but without any luck.
    Please let me know if you need any more information.
    Link to site can be sent via e-mail since i don’t want it to go public.

    #30
    Hassan
    Post count: 955

    Hi,

    It is new style ‘name’ not new style path so you should enter ‘main.css’ for it and not ‘template/main.css’ !

    PS:
    You can always check private option to make replies private here 🙂

    #31
    adamxerxes
    Post count: 12
    This reply has been marked as private.
    #32
    Hassan
    Post count: 955

    Glad to hear it works!

    Maybe you have another page with ‘page’ slug or another plugin uses it for its own URLs.

    Please also note that ‘page’ slug and ‘paged’ slug (i.e. previous and next pages) should be different.

    #34
    adamxerxes
    Post count: 12
    This reply has been marked as private.
    #40
    adamxerxes
    Post count: 12
    This reply has been marked as private.
    #41
    adamxerxes
    Post count: 12
    This reply has been marked as private.
    #45
    Hassan
    Post count: 955

    Hi Again,

    I just checked it out. It seems you have problem with htaccess. I disabled HMWP but there was still problem with pages. This means another plugin made a change in your WP.

    Check your htaccess file and disable all other plugins.

    If you could provide FTP account I can also do it for you.

    #63
    adamxerxes
    Post count: 12
    This reply has been marked as private.
    #65
    Hassan
    Post count: 955

    Well, I disabled all plugins but even default WP permalink doesn’t work. It seems the problem is beyond WP.

    Simply contact your host support and ask them about mode_rewrite module for Apache. They should know what the problem is.

    • This reply was modified 7 years, 8 months ago by Hassan.
Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.