Home Forums WordPress Plugins Hide My WP CRON Problem!

This topic is: not resolved

This topic contains 27 replies, has 4 voices, and was last updated by  Suman M. 1 month, 2 weeks ago.

Viewing 13 posts - 16 through 28 (of 28 total)
  • Author
    Posts
  • #18819
    Vikas Singhal
    Post count: 218
    This reply has been marked as private.
    #18827
    webagencyba
    Pro
    Post count: 37
    This reply has been marked as private.
    #18838
    Vikas Singhal
    Post count: 218

    I will try that, but it will take some time. I will keep you posted.

    #26347
    aqt
    Pro
    Post count: 41

    Was there any solution for this, I have the 2 cron jobs
    pp_important_messages3
    check_plugin_updates-hide-my-wp

    Stuck at the top of the crons.

    The issue sometimes is also reported by /wp-admin/site-health.php in WP 5.2

    #26348
    Suman M.
    Post count: 10485

    Hi aqt, I’ll check with our Dev Team and get back to you. Thanks!

    #26391
    aqt
    Pro
    Post count: 41

    Any updates? Can i disable those 2 crons in child theme functions.php? I can manually download and install the plugin every time it’s udpated.

    #26392
    Suman M.
    Post count: 10485

    Hi Pro, you can disable those crons but then you won’t be able to auto update plugin. Yes you can manually update the plugin.

    #26396
    aqt
    Pro
    Post count: 41

    Can you tell me how to disable those crons in child functions.php or provide a fix for this? thank you

    #26398
    Suman M.
    Post count: 10485

    You’ll need to manually update HMWP code

    For check_plugin_updates-hide-my-wp:
    Change

    public $checkPeriod = 12

    to

    public $checkPeriod = -1

    in
    /lib/plugin-update/plugin-update-checker.php

    For pp_important_messages3:
    Change

    function register_messages(){

    to

    function register_messages(){ return false;

    in
    /lib/class.helper.php

    • This reply was modified 1 month, 3 weeks ago by  Suman M..
    #26488
    aqt
    Pro
    Post count: 41

    I’m sorry but I can’t see this reply, it’s been marked as private. should I start a new thread?

    #26496
    Suman M.
    Post count: 10485

    Hi, I’ve made my previous reply public now. Can you please check?

    #26504
    aqt
    Pro
    Post count: 41

    Thank you that did the trick for pp_important_messages3 but the check_plugin_updates-hide-my-wp is still there at the top. I run the cron event and it is still there, I delete the event, and it is still there. (All that through the wp crontrol plugin)

    #26508
    Suman M.
    Post count: 10485

    Hi, we’ll check what’s the issue with check_plugin_updates-hide-my-wp, and will fix it in the upcoming versions.

Viewing 13 posts - 16 through 28 (of 28 total)

You must be logged in to reply to this topic.