Home Forums WordPress Plugins Hide My WP Wp-admin folder

This topic is: not resolved
Viewing 15 posts - 1 through 15 (of 63 total)
  • Author
    Posts
  • #4721
    dej8
    Post count: 65

    Hello!

    Cool plugin, I find it very useful for my site 🙂 thank you!

    Questions or you:

    1. I just set up everything to run on medium more compatibility. Some plugins still show name and the wp-admin folder still shows and was not changed (all others were)

    Can you please assist why this would still be showing these ones?

    2. If running on medium more compatibility, and you are not changing the New wp-admin Path*, what line of code should I place in my htaccess file?

    When I set this up manually, I first changed the New wp-admin Path*, but had the error of not hiding the mydomain.com/wp-admin login area. As soon as I followed your instructions it gave to 404 page!

    Please confirm what line of code I should place in my htaccess file, if need be!

    Thank you!

    #4725
    Suman M.
    Post count: 11284

    Hi, for renaming plugins, please set “rename plugins” options to “all plugins” in HMWP permalinks & urls tab.

    To change/rename wp-admin path, you have to enter the replacemnet name in “New wp-admin Path” option; and then you have to very carefully follow onscreen instructions. Basically, you’ll need to do these:

    – in wp-config.php you need to add following line before require_once(…):
    define(“ADMIN_COOKIE_PATH”, “/NEW_WPADMIN_NAME”);

    – update your .htaccess file by adding following line before ‘RewriteCond REQUEST_FILENAME} !-f’:
    RewriteRule ^NEW_WPADMIN_NAME/(.*) /wp-admin/$1 [QSA,L]

    #4749
    dej8
    Post count: 65

    Helloo!

    I did this, and all folders changed except for the wp-admin/css folder. I see this when I use chrome and go to inspect element – sources.

    I originally changed- define(“ADMIN_COOKIE_PATH”, “/panel”); , RewriteRule ^panel/(.*) /wp-admin/$1 [QSA,L], for my hta and wpconfig folder. However still showing.

    I also had the issue of not being able to delete users from the wpadmin folder and no 404 pages were showing when I went to mydomain.com/wp-admin, it was just taking me directing to my new login page.

    Suggestions?

    #4750
    dej8
    Post count: 65

    *note, I changed to wp-admin folder to show panel

    #4759
    Suman M.
    Post count: 11284
    This reply has been marked as private.
    #4770
    dej8
    Post count: 65
    This reply has been marked as private.
    #4771
    dej8
    Post count: 65
    This reply has been marked as private.
    #4777
    Suman M.
    Post count: 11284

    I activated HMWP and applied “medium privacy more compatibility” settings and it seems to be working fine. Now, direct access to http://www.helloclean.ca/wp-login.php and http://www.helloclean.ca/wp-admin/ is not allowed; you can access it via http://www.helloclean.ca/wp-login.php?hide_my_wp=1234
    (“hide_my_wp=1234” is a default security key and you can change from HMWP general; settings tab)

    Now, do you also want to change wp-admin path name? We recommend you to change this only if required as it requires manual change in wp-config.php; and also access to default login URLs is now blocked. Let us know.

    #4784
    dej8
    Post count: 65
    This reply has been marked as private.
    #4792
    Suman M.
    Post count: 11284
    This reply has been marked as private.
    #4796
    dej8
    Post count: 65
    This reply has been marked as private.
    #4797
    dej8
    Post count: 65
    This reply has been marked as private.
    #4808
    Suman M.
    Post count: 11284

    I’ve assigned this ticket to Sr. support to have further look into it. He shall get back to you soon.

    #4810
    dej8
    Post count: 65

    Thank you

    #5753
    dej8
    Post count: 65
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 63 total)

You must be logged in to reply to this topic.